Warning: Use of undefined constant HTTPS - assumed 'HTTPS' (this will throw an Error in a future version of PHP) in /home/startinn/public_html/home/blog/post.php on line 7

Warning: Use of undefined constant HTTPS - assumed 'HTTPS' (this will throw an Error in a future version of PHP) in /home/startinn/public_html/home/blog/post.php on line 7
Tudo sobre a função PROCV do Excel - Startinn

Tudo sobre a função PROCV do Excel

Publicado em 11/12/2016 | (0) comentários

Sabe quando você quer encontrar o telefone de alguém em uma lista telefônica? Você procura pelo nome para em seguida encontrar o telefone ou endereço. A função PROCV do Excel faz exatamente isso!

A PROCV realiza a busca de um determinado valor em uma matriz de células, caso o valor procurado seja encontrado, uma das colunas da matriz é retornada. O valor procurado poder ser exato ou semelhante.

Declaração da função PROCV

A função PROCV é declarada com os seguintes argumentos:

=PROCV(valor_procurado ; matriz_tabela ; número_índice_coluna ; [procurar_intervalo] )

valor_procurado
O que eu desejo procurar?
matriz_tabela
Onde eu desejo procurar?
número_índice_coluna
Quando eu encontrar o que procuro, qual coluna da matriz eu quero mostrar?
[procurar_intervalo]
Desejo procurar um valor idêntico ou semelhante? 

Exemplo prático

Neste exemplo iremos pesquisar na coluna ID o número 6, quando encontrarmos o número 6 iremos apresentar a coluna 3, ou seja, o nome:


Nossa fórmula ficará assim:

=PROCV(C3;A7:C14;3;FALSO)

Nesta fórmula procuramos na matriz A7:C14 o valor 6 que está na célula C3. Ao encontrar o valor, a fórmula irá apresentar o conteúdo da coluna 3 da matriz, ou seja, o nome "Marcos Esteves".

Apresentando a coluna 2 (nascimento) ao invés da 3

Para apresentar outra coluna, basta alterar o núm_índice_coluna, ou seja, altere para 2 para retornar a coluna nascimento.

Procurando valores semelhantes

O argumento [procurar_intervalo] determina se a pesquisa pelo valor procurado irá considerar somente se existir um valor exatamente igual ou um valor semelhante.