Warning: Use of undefined constant HTTPS - assumed 'HTTPS' (this will throw an Error in a future version of PHP) in /home/startinn/public_html/home/blog/post.php on line 7

Warning: Use of undefined constant HTTPS - assumed 'HTTPS' (this will throw an Error in a future version of PHP) in /home/startinn/public_html/home/blog/post.php on line 7
Tudo sobre a função ÍNDICE - Startinn

Tudo sobre a função ÍNDICE

Publicado em 04/02/2017 | (0) comentários

Imagine uma lista de supermercados de centenas de itens. Você precisa selecionar o 132º item desta lista. Neste momento você está selecionando da lista de itens o índice número 132. No Excel, a função ÍNDICE permite que você escolha qual item de uma lista deseja retornar.

Declaração da função

A função ÍNDICE pode ser declarada de duas formas

Uma única matriz

=ÍNDICE(matriz; núm_linha; [núm_coluna])
matrizMatriz ou intervalo de onde se deseja obter o valor baseado no índice
núm_linhaNúmero do índice, ou seja, a linha que deseja se retornar da matriz
[núm_coluna]Número da coluna que deseja retornar os valores da matriz

ou

Múltiplas matrizes

=ÍNDICE(ref; núm_linha; [núm_coluna]; [núm_área]
refConjunto de matrizes de onde se deseja retornar os valores
núm_linhaNúmero do índice, ou seja, a linha que deseja se retornar da matriz selecionada
[núm_coluna]Número da coluna que deseja retornar os valores da matriz selecionada
[núm_área]Número da matriz do conjunto de matrizes

Veja abaixo um exemplo:

Exemplo prático

Retornando um item de uma matriz

Abaixo temos uma lista de estados brasileiros. Através da função ÍNDICE iremos pegar um valor e apresentar na célula D3.


Retornando um item de várias matrizes

Com a função ÍNDICE é possível retornar o índice de mais de uma matriz, sendo possível escolher de qual matriz se deseja obter os valores do índice.


No exemplo apresentado acima, criamos duas matrizes representadas pela Tabela1 (A3:A10) e Tabela2 (C3:C6). Note que as duas matrizes estão envolvidas por um parênteses:

 =ÍNDICE((Tabela1[Matriz 1];Tabela2[Matriz2]);2;1;1)

Dentro dos parênteses você pode adicionar diversas matrizes. Em seguida informar qual linha deseja obter do índice. No nosso caso pegamos a linha 2, ou índice 2

 =ÍNDICE((Tabela1[Matriz 1];Tabela2[Matriz2]);2;1;1)

Escolhemos a coluna 1, afinal nossa matriz só tem 1 coluna

 =ÍNDICE((Tabela1[Matriz 1];Tabela2[Matriz2]);2;1;1)

Por fim, escolhemos qual área ou matriz desejamos considerar para obter o valor do índice

 =ÍNDICE((Tabela1[Matriz 1];Tabela2[Matriz2]);2;1;1)
O resultado da nossa fórmula será "ACRE", pois estaremos pegando o índice 2 da primeira planilha. Se alterarmos o [núm_área] para 2, o resultado será "PARANÁ", pois estaremos pegando o índice 2 da segunda matriz.

Categoria: índice função