Warning: Use of undefined constant HTTPS - assumed 'HTTPS' (this will throw an Error in a future version of PHP) in /home/startinn/public_html/home/blog/post.php on line 7

Warning: Use of undefined constant HTTPS - assumed 'HTTPS' (this will throw an Error in a future version of PHP) in /home/startinn/public_html/home/blog/post.php on line 7
Tudo sobre a função DIA.DA.SEMANA - Startinn

Tudo sobre a função DIA.DA.SEMANA

Publicado em 15/03/2017 | (0) comentários

A função DIA.DA.SEMANA do Excel retorna, a partir de uma referência de data, o dia da semana que a data representa, considerando o parâmetro tipo de retorno, por exemplo, se você decide que o retorno será 1 para Domingo e 7 para Sábado, ao apresentar a data 10/03/2017, o Excel mostrará o número 6, pois esta data cai em uma Sexta-feira, pois:

  1. Domingo
  2. Segunda-feira
  3. Terça-feira
  4. Quarta-feira
  5. Quinta-feira
  6. Sexta-feira
  7. Sábado

Declaração da função

A função DIA.DA.SEMANA é declarada da seguinte maneira:

=DIA.DA.SEMANA(núm_série; [retornar_tipo])
núm_sérieReferência que contém o valor de data de onde deseja-se retornar o dia da semana que a data representa. O núm_série pode ser uma referência de célula, nome, ou mesmo uma data inserida entre aspas duplas
[retornar_tipo]

Define qual número será retornado para cada dia da semana. As opções são as seguintes:

1. Números de 1(domingo) a 7(sábado)

2. Números de 1(segunda-feira) a 7(domingo)

3 - Números de 0(segunda-feira) a 7(domingo)

11. Números 1(segunda-feira) a 7(domingo)

12. Números 1(terça-feira) a 7(segunda-feira)

13. Números 1(quarta-feira) a 7(terça-feira)

14. Números 1(quinta-feira) a 7(terça-feira)

15. Números 1(quinta-feira) a 7(quarta-feira)

16. Números 1(sábado) a 7(sexta-feira)

17. Números 1(domingo) a 7(sábado)

Exemplo prático

No exemplo abaixo, iremos ocultar os finais de semana de uma lista de datas crescentes a partir da data de hoje. Para este efeito, utilizaremos as funções SE e DIA.DA.SEMANA em conjunto. A fórmula é a seguinte:

=SE(DIA.DA.SEMANA(A2;1)=6;A2+3;A2+1)

Considerando que a fórmula está na célula A3, ficaria da seguinte maneira:

=SE o dia da semana da célula de cima (no caso A2) for sexta-feira (6), somo a célula de cima com 3, se não for, somo com 1 para aumentar um dia.


Com isso, basta arrastar a fórmula para baixo que a lista de datas irá desconsiderar os finais de semana

A coluna B apresenta o dia da semana por extenso, para demonstrar o resultado

Baixe aqui a planilha pronta